Much ado about scripting, Linux & Eclipse: card subject to change


Kernel Panic!

Yesterday a very nasty linux security hole was uncovered & shortly thereafter, fixed.

Tonight I attempted to upgrade my home systems and discovered that my desktop is immune (Kubuntu 6.06LTS, kernel 2.6.15-27-686 SMP i686) as this bug only manifests with kernel 2.6.17 or later.

My laptop (AntiX 7.0, 2.6.22-1-mepis-smp i686) decided to kernel panic when I upgraded to 2.6.22-3-686 & restarted. But that upgrade was pointless anyway, as the only Debian fix yet available is kernel 2.6.18 for Debian 4.0 (Etch).

So, switching to the Ubuntu repository, I found the fix I need. Here's a list of the kernel upgrades by *ubuntu version/name:

  • 6.10 (Edgy): 2.6.17-12
  • 7.04 (Feisty): 2.6.20-16
  • 7.10 (Gutsy): 2.6.22-14

If you're like me and your AntiX/MEPIS/Debian/Kubuntu hybrid doesn't already have packages for these fixes, you can add these repositories to your /etc/apt/sources.list by hand:

# Ubuntu Security Updates
deb gutsy-security main restricted universe multiverse
deb-src gutsy-security main restricted universe multiverse

However, if your system is anything like mine, it won't even bother to kernel panic on restart -- instead, you'll get a dead system with the caps lock light blinking on & off. Yes, that's definitely more secure than before. :(