Much ado about scripting, Linux & Eclipse: card subject to change


Visual Editor for Eclipse 3.4 Ganymede

There have been a number of questions in eclipse.newcomer lately about the availability of a visual editor for Eclipse 3.4 Ganymede.

So, I thought I'd see if VE 1.3 can be installed into Ganymede using p2 -- and in fact it's pretty easy to do.

As noted in VE Installation Guide, you can use the "Eclipse IDE for Java EE Developers"... but because I usually run with the Eclipse SDK, rather than an EPP bundle, I wanted to know what the minimum requirements are for VE, so I unpacked VE into Eclipse's new dropins/ folder, and started Eclipse with the OSGi console active, using this script:

pushd ~/eclipse/34clean >/dev/null
if [[ $# -eq 0 ]]; then
        rm -fr eclipse $workspace emf-unpacked
        echo "Unpack $eclipse...";
        tar xzf $eclipse
        echo "Unpack ${ve}.zip into dropins"
        unzip -q ${ve}.zip -d eclipse/dropins/ve
        mv eclipse/dropins/ve/$ve eclipse/dropins/ve/eclipse

echo "Using vm=$vm and workspace=$workspace"; 
./eclipse/eclipse -vm $vm -data $workspace \
  -consolelog -clean -debug -console -noexit -vmargs \
  -Xms128M -Xmx256M -XX:PermSize=128M -XX:MaxPermSize=256M
popd >/dev/null
What I found was that the console listed all the missing dependencies for the VE feature, making it easy to find the features I needed to install to fully enable VE. I fired up the Help > Software Updates and installed the following from the Ganymede Update Site:

On restart, I had a working visual editor:


Emanuele Ziglioli said...

Indeed P2 is quite an improvement!

Could you try creating a ViewPart for a PDE plug-in? it doesn't work for me with the VE version I've got (all the rest does).
I'm using the version of VE provided by Yves YANG

nickb said...

Can you detail the steps you followed? I've tried creating a plugin project using the "with a view" template, but when I open the SampleView class w/ the visual editor, I get a NPE:

at org.eclipse.gef.editparts.AbstractEditPart.activate(

(This occurs with the latest binary VE build from ehecht, dated, 1.3.0.v200805121900.)

Emanuele Ziglioli said...

Same... for some reasons creating classes that extend ViewPart causes an exception.
But I have no problems with creating normal SWT panels. So I create them indipendently with VE and then I manually insert them in a ViewPart that I open with the normal editor, not VE.

nickb said...

Sounds like something that the VE team ought to weigh in on. Please open a bug.

Emanuele Ziglioli said...


It's my first bug report, so I hope I've provided enough info

Paul said...

I have been trying to get VE (lin_mac 1.4 version) to work on Ganymede installed on Ubuntu x86_64 with no success. I tried following both the instructions here and on the wiki. Eclipse appears to be ignoring VE's existence in the dropins directory. I even tried copying the jars/directories to the features/plugins directories. Any suggestions?

nickb said...

Could be a conflict between 32- and 64-bit libraries -- in theory, you need a 64-bit version of VE.

Have you tried a 32-bit Eclipse?

Paul said...

I haven't. I'll see what I come up with. I did get a little further. I had a package conflict that was preventing the VE installation from completing. It at least shows up in my installed packages list now. However, I still don't see an entry for the editor under Preferences. Working on resolving some other possible conflicts first.

Paul said...

Well, something appears to be a problem with the 1.4 build. I was able to get the build from May to work. Thanks for your time.

AP said...

Found this VE packaged version for 3.4 Ganymede. Seems to work fine for me:

Eko SW said...

thx for the last post. i'll test it.

nickb said...

Actually, we have something much newer - I've been remiss in not posting an update.

Latest downloads, for Eclipse 3.4+:

Latest updates, for Eclipse 3.4+: